【P神开源】易语言多开中控源码|秒变多线程【视频详解】

发表于:2018-11-01


【雷电模拟器专用模板-多线程控制台】
视频详解已更新: 优酷搜索:第一章 易语言大漠中控模块详解观看地址:https://v.youku.com/v_show/id_XMzk3OTkyMTA2NA==.html?tpa=dW5pb25faWQ9MTAzMjUyXzEwMDAwMV8wMV8wMQ
或者我自己提供的功能,点击帖子的分享链接即可

【更新说明】这次给出来的框架可以控制单开CPU0-1%之间的写法
研究了1下午,从11%优化到7%到最后的1%。希望大家喜欢。
2018-11-24-22:21
本次更新比较大,做了个简单的游戏的模板,单开配置也做进去了
秒转中控部分做了备注,配置放入中控启动懂窗口下面的子程序
用我的单开模块,写单开脚本,其实都方便很多,采用了任务栈的方式处理
用这套东西写脚本,只需要填空直接写脚本内容就可以了
所有的框架都给出来了
填空最简单的方式了。然后复制进中控,就是中控脚本了!
框架从单开脚本,到多线程脚本全部给出来了
包括之前提到的账号列表的读写方式。源码中也给出来了
当然更多分享在P神交流群中能获得更多的信息,因为P神几乎每天都有免费分享
给大家讲解如何使用,快速开发脚本。
具体下载地址,请到百度网盘下载吧,因为这里放不下那么多,并且开源了自己写的常用的模块。
其中包含了易大漠汉化部分
和一些特殊文本处理方法
后期更新百度OCR接口。同样,回复后获得下载地址。


【P神开源】易语言多开中控源码|秒变多线程【视频详解】【P神开源】易语言多开中控源码|秒变多线程【视频详解】【P神开源】易语言多开中控源码|秒变多线程【视频详解】【P神开源】易语言多开中控源码|秒变多线程【视频详解】【P神开源】易语言多开中控源码|秒变多线程【视频详解】【P神开源】易语言多开中控源码|秒变多线程【视频详解】【P神开源】易语言多开中控源码|秒变多线程【视频详解】
其它模拟器请自己修改
此模板会持续更新增加示例,此套源码中,给出了多线程中控实现的例题
【很多童鞋下载后提示-0,-8错误,请卸载原大漠,安装最新版本大漠即可,此版本因使用COM组件MTA模式注册,因此需要大漠VIP版本才能正常使用】
【源码为大漠官方给出的多线程例子,配合雷电模拟器官方给出的开源模块编写而成,感谢大佬们的分享,兄弟们顶起来,真的是好东西哦】
已实现功能
1.启动即可检测所有雷电模拟器
2.可自由选择启动模拟器
3.可自由启动线程,点击全部启动,启动已选模拟器对应的线程。

放心不会重复启动不会乱,只启动选择的,如果选择已经启动,会自动识别
4.可实现单停,全停,暂停,恢复,单窗口重启线程
5.直接按照我的说明写单开脚本,放入接口,即可完美时间多线程操作。
6.中控功能给出案例,自己研究,后期我会陆续更新功能,包括找色全分辨率识别算法

7.重要的事情说三遍:简单,简单,简单。
只要你不修改界面设置,你只需要在接口写入你单开操作的代码,就可以直接实现中控
看懂我画箭头的提示即可 非常简单!!

启动窗口标题,直接修改属性即可改变,下面2行字是状态条文本,
0和1 2项直接在启动窗口创建事件中 状态条1.置文本(0,""),状态条1.置文本(1,"")即可修改。可以直接置空

更新日志================================
2018年11月14日
更新增加了单开脚本SPY++的写法
更新增加了单开脚本接入中控的演示,因为不允许上传大附件,请进群:48833526下载完整压缩包
演示讲解视频地址:http://rec.buka.tv/5be98d924edfb248ff006225?room_id=1105315&v=5.0&share_whether=1




2018年11月6日11:34更新
由于很多朋友在使用的时候因为大漠插件版本的差异问题以及很多朋友不知道如何封装和释放大漠插件
所以我已经更新写出了例子,并且加入了子程序
由于论坛不支持大附件,所以源码中不带资源文件,懂得人自己添加,不懂的进群:48833526群文件下载吧,雷电不支持大文件抱歉了
.版本 2

.子程序 释放大漠插件且注册到系统
.参数 参数_是否释放大漠插件, 逻辑型, 可空
.局部变量 P_ver, EDM

.如果真 (是否为空 (参数_是否释放大漠插件) = 真)
参数_是否释放大漠插件 = 真
.如果真结束

.如果真 (参数_是否释放大漠插件 = 真)
写到文件 (取运行目录 () + “\dm.dll”, #大漠插件)
运行 (“regsvr32 ” + #引号 + 取运行目录 () + “\dm.dll” + #引号 + “ -s”, 真, ) ' 注册大漠插件到系统
.如果真结束

你只需要传入真 即可释放大漠插件并且注册大漠插件到系统,传入假即不释放也不注册大漠插件

代码卸载了启动窗口创建时间内,直接可以看到,里面有备注

=============================================
2018年11月5日22:56更新
1.增加了更新 显示返回脚本执行结果 的方法【见代码内做任务代码和主线程调用做任务代码】
2.绑定模式参数修改直接在常量表中修改即可
=============================================
2018年11月1日 8:55更新
1.修复已知问题:初始化大漠全局对象路径以及设置如下
.版本 2

' 这里我们设置一下全局字库
全局大漠.SetPath (取运行目录 () + “\test_game”)
全局大漠.EnableShareDict (1)
' 全局大漠.SetDict (0, “1.txt”)‘没有增加字库自行添加

2.修复图色绑定模式"gdi”为“dx.graphic.opengl”模式,否则图色不正常
不能正常验证的,请尝试提升管理员权限。或者重新注册大漠插件,太累了,因为我的权限不足,所以我没办法上传大文件,因此不能给你们写自动释放
插件且注册的方式,需要你们自己重新注册下大漠插件到系统,用大漠插件里
里的 注册大漠插件到系统.bat 就可以


此版本为第一版:2018年11月1日发布,会持续更新,请关注此贴
请回复获取
【中控脚本-易语言源码-中控传参源码】
及解压缩密码回复有惊喜

[hide=d30]解压缩密码778899
多线程中控模板20181105.rar
2018年11月24日,更新,由于内容比较多,所以请在网盘下载吧,自己随手写的一个游戏实例,目的是优化CPU占用和堆栈任务流程演示
如果你不会,那么请直接填空就好了。非常方便了
链接: https://pan.baidu.com/s/1RXyICH79b77oIKwinJoAEA 提取码: 5fwr 复制这段内容后打开百度网盘手机App,操作更方便哦
易语言-文本传参中控的实现.rar
多线程模板-大漠原版所有窗口均可套用.rar
雷电_模拟器操作模块_摘自雷电置顶贴.rar
[/hide]

更多关于模板使用的需求及建议,您可以
加入P神编程分享QQ群:792360300
每周都会有精彩的易语言编程直播分享

更多关于脚本使用的需求及建议,您还可以直接加入雷电安卓模拟器脚本交流QQ群:
390643657

更多精彩的手游电脑版游戏攻略、辅助、玩家交流、抽奖活动;敬请关注雷电:

雷电安卓模拟器:https://www.ldmnq.com

雷电游戏中心:http://app.lq.com

雷电官方Q群:点击加群








nullnull
评论(354)
  • gamejk

    2018-11-01

    这真的支持 是沙发么?
    • P神 :
      谢谢支持。!~~~~
      2018-12-19 回复
    点赞(0) 回复
    • 举报
  • 紧肛互撸娃

    2018-11-01

    1111111111111111111111111111111
    点赞(0) 回复
    • 举报
  • 囧架架囧

    2018-11-01

    谢谢了``````````
    点赞(0) 回复
    • 举报
  • 雷电阿星

    2018-11-01

    :lol支持,支持~~
    点赞(0) 回复
    • 举报
  • ld8042626202

    2018-11-01

    哈哈哈哈哈,太棒了
    点赞(0) 回复
    • 举报
  • sshc520

    2018-11-01

    :dizzy::dizzy::dizzy::dizzy::dizzy::dizzy::dizzy:
    点赞(0) 回复
    • 举报
  • ld8032060671

    2018-11-01

    支持支持支持支持支持支持支持
    点赞(0) 回复
    • 举报
  • 岁月

    2018-11-01

    6666666666666666666666666666666666666666
    点赞(0) 回复
    • 举报
  • falwpl

    2018-11-01

    大神。。。。。。。。
    点赞(0) 回复
    • 举报
  • 我爱楼主

    2018-11-01

    好厉害1!!!!!!!!!!!!!!
    点赞(0) 回复
    • 举报